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Thank you very much for selecting TK8 Safe! 

TK8 Safe can keep your passwords, serial numbers and other
sensitive information in a highly encrypted file. You can password
protect the archive, so no one but yourself can access the data.
But for you using the information is fast and easy. 

Most about TK8 Safe is described in this manual. Just locate to
the topic you are interested in. 
 
If you have any questions, suggestions or comments, please
contacts us.
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1 TK8 Safe

1.1 Description

  
TK8 Safe is a perfect password manager with features that covers all aspects of storing and using
sensitive information. 

If you have passwords, then TK8 Safe can make your life easier.

You can keep all user names, passwords, secret notes and serial numbers in one secured database
file. The file is encrypted and not available to anyone else than you. 

It means no more lost passwords and headache remembering them. No more fears strangers can
see or use your information. It's safe and simple! 

TK8 Safe password manager not only stores your information, but also helps you to use it. Nice and
fast user interface makes it easy to find required information quickly. You can also use folders in
your files to group the information. Searching, sorting and finding passwords has never been easier.

Log in to password protected web pages automatically! Just select "Auto-type" from the menu or
press system wide hot key on the login prompt. The program will locate the required entry
automatically and fills the login prompt for you.

If needed, you can also launch web pages related with password entries and use classic Copy and
Paste commands. 

The password file can be locked if you leave the room, so the information remains always protected.
Even if you forget to lock the file, the program will do this automatically after unused for some time.

Advanced users have many options and additional features like encryption options, same-time multi-
user access, custom fields for each entry, automatic password backups, recycle bin, favorites, etc..
By using system wide hot keys you can call different TK8 Safe commands whatever other program
is active, built in password generator can be useful on creating new secure passwords, etc.

If you like, you can use the program in the system tray mode. In this way no room is taken away
from your taskbar. And you can still access all the features easily by clicking on the tray icon (next
to the Windows system clock). 

The program is also portable, which means you can run it directly from any removable media like
USB memory discs. So you can carry your file and the program in the pocket, knowing only you can
access the information.

Help file and manual are included with the program so you could get to know all the features and
benefits TK8 Safe can offer.   
 
 
Minimum System Requirements:
Windows 98, NT4, ME, 2000, XP Home, XP Pro, 2003 Server, Vista;
400 MHz or better Pentium® processor or equivalent;
about 10 MB of free disc space;
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1.2 Features

Top 5 features current users love most:

1) Auto-typing login prompts; 
2) System tray mode;
3) Fast and feature-rich navigation on the table (sorting, searching and filtering);
4) Different folder types to store different kind of information better; 
5) System Wide Hot keys and Auto-Type memory

 

Feature Highlights:
 

· Easy to understand and fast user interface
· Single user selectable master password to access password database file
· Encrypted data files (by default AES 256 bit security). AES 128, Blowfish 448 and others

available in the Professional version.
· Possibility to run from USB drive

· Unlimited entries and folders per file
· Special forms designed to keep different information better: 1) General login entries; 2) Card

entries; 3) File encryptions, 4) Secure notes, 5) Serial numbers
· Ability to store unlimited custom fields and values for each entry

· Auto-type command to fill login prompts automatically. Advanced users can use customised
auto-type templates.

· Classic clipboard (copy and paste) functions
· Run command to launch web sites or file links related with the entry. Opens new browser

window for this, meaning it does not change the current page you are on, if your browser is
already open.

· Custom sorting, grouping and column order on the entry list. 
· Quick search to find entries - just start typing on the entry list. 
· Advanced find and filters.
· Favorite entry list
 
· System tray working mode
· Tiny password bar working mode.

· Password generator to create new secure random passwords easily
· Password generation based on templates (in the Professional version)
· Built in tool to encrypt and decrypt external files on your hard drive (in the Professional version).
· Recycle Bin and Undo features

· Possibility to mask and hide sensitive information
· Locking the file automatically after unused for some time.
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· Possibility to export entries to Excel, Text files, HTML and XML. Importing from text files.
· File Synchronization (in the Professional version)
· Printing entry lists.

· Drag and drop support for entries and folders.
· Auto backup features built in

· Support for multiple files
· In the Professional version: multiple users can access the same file at the same time (having

full access to the file).
· In the Professional version: user permission system, meaning feature and folder based

restrictions for different users.
· In the Professional version there is also possible to e-mail entry information, use history log and

templates for custom fields.

· Windows XP user interface look support. Customization options for look and feel, including
custom icons for your entries and folders.

· Multi language support
 
 

1.3 Standard vs. Professional

 
Professional version has all the features of Standard version, plus:

· Possibility to use different encryption algorithms (instead of default AES 256)
· Onscreen keyboard for entering database master password
· Synchronization
· Login Groups
· Access to the file with multiple sessions (same-time multiuser access).
· Option to email login info (on different templates, if required)
· History log feature where you can see every change made in the database
· Templates to load default field names (and values) to login entry additional fields
· File Operations module to encrypt and decrypt external files. Secure Delete function for external

files
· User permission system (access restrictions to different folders and feature based restrictions)

 

1.4 Security

By default TK8 Safe uses AES encryption algorithm to protect your data file. 

AES stands for Advanced Encryption Standard. It is a symmetric key encryption technique which
will replace the commonly used Data Encryption Standard (DES). It was the result of a worldwide
call for submissions of encryption algorithms issued by the US Government's National Institute of
Standards and Technology (NIST) in 1997 and completed in 2000. The winning algorithm, Rijndael,
was developed by two Belgian cryptologists, Vincent Rijmen and Joan Daemen.
 
AES provides strong encryption and has been selected by NIST as a Federal Information Processing



TK8 Safe

- 6 -

Standard in November 2001 (FIPS-197), and in June 2003 the U.S. Government (NSA) announced
that AES is secure enough to protect classified information up to the TOP SECRET level,
which is the highest security level and defined as information which would cause "exceptionally
grave damage" to national security if disclosed to the public.
 
The Standard version uses AES 256-bit keys to protect database files. That is a combination of
superb security and fast encryption. In the Professional version you can use additional encryption
algorithms like BlowFish with 448 bit keys, Twofish, Square, etc.
  
 

2 Quick start tutorial

2.1 Starting the program

After the program is installed, you can start TK8 Safe in several ways:

1) From Start menu Programs folder, select TK8 Safe folder and click on the TK8 Safe icon. 

2) If the TK8 Safe icon is on the desktop, you can run the shortcut by double-clicking on its icon.

3) TK8 Safe has also file association with files having TKS extension (File type). It means that when
you double-click on some TK8 Safe database file, the program is started and the program will open
that file (of course the master password is required if the file is password protected).
 
 

2.2 Creating a new file

 
To start keeping your information in the secure database, you have to create a new TK8 Safe file. 
 
To do this, click on the "File" menu and select "New..."
 
On the appearing dialog enter the file name and click 'Save'
 
 

2.3 File properties

File properties window is opened automatically when creating a new file. 
 
Later, after the file is created, you can change your file properties by opening File menu and
selecting Properties. You will be asked for a password to access this information.
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General info
 
On the General info panel you can set the descriptive title to your file and enter the master password
that protects your file. This password is required every time the file is accessed or opened. To set
the password you want to use, just enter it to the "Database password" field. To prevent typing
errors, please verify the password by typing it also to the "Confirm ..." field.
 
If you leave the password fields empty, your file will not be password protected. This might be good
only when you are sure no one else than you can access your computer and the file -or- the file
contains no sensitive information. Though, we strongly suggest you to password protect any file. 
 
WARNING: Please make sure you do not forget the master password! If you lose it there is
no possibility to access your information in the file. Even we are unable to get any
information from the file so we can not help you when the master password is forgotten.
 
In the Professional version, you can also select the preferred file encryption method. 
  
 
Settings

On the Settings tab how many records should the program keep in the history table. That is the
amount of commands you can undo or watch and revert in the history log. Additionally, you can set
which actions exactly should be kept in the history log.
 
 
Users & Permissions (available in the Professional version only)
 
If you want to set up permission system for your file, meaning you can set which user has the
access tothe file and to what kind of information, you can set it on this panel. You can read more
about user permission system from the chapter "User permissions".
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2.4 User Interface

2.4.1 Layout

TK8 Safe has an easy to understand user interface you can see below:

You can use the main menu (1) and buttons on the toolbar (2) to access commands and different
program modules. Every password database file you created with TK8 Safe can have different folders
and sub folders (3). Each folder can have unlimited amount of entries, which are seen in the entry list
(4).

In addition you can right-click with your mouse on the folder tree (3) or in the entry list (4) to open
different pop up menus.

You will find more information about TK8 Safe by reading through the following chapters.
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2.4.2 Folders

 
Folders are good in case you want to keep information grouped in your file. 
 
By default your file has some folders inside when you create it, but the number of folders is not
limited. So you can have as much folders as you need, and delete those you do not want any more. 
 
You can manage folders at any time opening the "Folder" selection in the main menu. When you
add or edit a folder, the folder detail window appears:
 

When adding a folder, you can select the folder type. Depending of the folder type you can keep
different kind of information about the entries on that folder. 
 
TK8 Safe has 5 different form designs built in to keep your information:

· Logins - to keep most of the login information
· Cards - to keep sensitive information about your credit, membership, and other cards.
· Files - to keep files securely inside your password database.
· Notes - to keep secure notes about your stuff
· Serials - to keep serial numbers of the software (and / or hardware) you have.

 
Please read the next chapter "Entries" to see exactly what values those different type of entries can
keep.
 
Additionally to type, you can select the icon for your folder, and finally enter its name.

TK8 Safe has a feature to show all records, including those from the sub-folders, when the folder is
selected. For this to work, you need to select "Yes" option to the last field on the Folder Properties
window. This feature is good when you have a lot of entries in different sub folders but often forget to
which folder the entry was added to. If this feature is activated, you can always find the entry from
the root folder entry list, but at the same time your data remains well organized.
 
  
Changing folder location and order

At any time you can change your folder structure and locations. For this just use your mouse and
drag the folder you need to the preferred location. Additionally, you can use Order submenu from the
Folder menu. That allows you to select which criteria is used to sort your entire folder tree, or if you
would like to use the custom order:
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That menu selection also helps you to move the selected folder one step up or down, and move it a
level higher in the tree if needed.
 
 

2.4.3 Entries

To add, edit or delete your user names, passwords and other information, you can use the "Entry"
menu or the buttons on the toolbar:
 

When you add or edit entries, entry detail window appears where you can fill the fields with
information you want to keep about your entry. As you might know already, depending the type of
selected folder, you can store different kind of information on your entries. 
  
Login entries

If the folder type is Logins, the entry detail window looks like this:
 

 

This type is good for storing any kind of user names and passwords. On the detail window you can
point out the account name, user name, password, and the web site address (for example) on the
link field. 
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You can also enter or select the additional description and notes about your entry if you like.
 
In case you need to store values for more fields, you can do this on the Additional Fields panel:

On this table you can store any kind of field values, on unlimited records. Similar to entries table,
you can use Add, Edit and Delete buttons to manage records. In the professional version you can
additionally use Templates to load pre-typed fields and values. 
 
On the main window, when you select the entry which has additional fields, the program will
automatically displays additional table at the bottom of the screen, with the field names and values.
You can manage access those values quickly when you right click on that appearing table.

Card entries

When the selected folder has type Cards, the entry detail window looks like this:

It is specially designed so you could store any kind of card information in the best way.

 
File entries are a bit different that other entries. They allow you to import any external file inside to
your database:
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When you import a file inside to your database, it is protected along with your passwords, and the
file is always with you, as long as you have your file. When you need to access the file, you can use
Export button on the window, and select the location where you would like to save the file. 
 

Note entries are best for you if you want to store some memos, for example, but want to make sure
nobody else has access to them. In such cases, you can just create a new folder for your secret
notes:

 
Serial Number folder type:
 
Most computer users have bought some software or hardware. In many cases the software has
license numbers, certificates, and other information that is also a proof of the purchase. It is easy to
lose such information, except keeping it in one place. TK8 Safe has special form designed to keep
your serial numbers:

When you store all your serial numbers inside your database, you can always access this
information fast should you re-install the program or request support from companies that require
order numbers from you to get support.

 
Details panel on Entry window

Each entry window has also the Details panel. Depending the entry type, you can keep different
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information there. For example you can store a photo of your card, see previous passwords of your
login entry, or change its Auto-Type template. You can also see when the entry was created (in
multi-user system also who created it), and when was it modified last time. Additionally you can
select the record and text color if you like.

 

2.4.4 Organizing icons and selection lists

 
Icons
 
Each entry and folder in your file can have an icon. When you open entry detail window, at right of its
title field (Account or Name), you can see a small drop down button. When you click on it, the menu
appears from where you can select the icon you like. When creating a new folder, or editing old one,
you will see a separate field for selecting the icon. 
 
By default when you create a new database file it already has a set of icons ready for you. But you
can change this list. For this, open the File menu and select "Organize Icon List". The window
appears where you can add new icons, or delete them from the list. When adding new icons, the file
has to be in BMP or ICO file format. The default size used for the icon is 16 x 16 pixels.
 
Selection list values
 
In several places in the program you can select pre-typed text with your mouse instead of typing it.
This is faster if you want to use similar values in some fields on a lot of entries. For example you can
have pre-made selections for entry description field, with values "Email account", "Personal account"
or "Business account". 
 
To add and manage those selection values, open the File menu and select "Organize Selection
Lists". When you add or edit a selection record, you can point out on which field the value should be
available for selection, and what exactly should be the selectable value. 
 
You can edit and delete available selections at any time. When you edit or delete some of the
selections, the text already selected to the entries will remain unchanged and is also not removed. If
you want this, you need to edit these records and remove or change the values manually.
 
 

2.4.5 Using your entries

Soon your file contains some entries, you can start using them easily. As all your user names and
passwords are in the one place, you can find them quickly and there is no threat you will forget
them.
 
If you need to log in to some web page, then probably the easiest is to just locate the entry of that
web page and copy the password (by using the Entry menu or the toolbar buttons). After copied, the
password can be pasted to the login window. 
 
When you open the "Entry" menu, you will see many different commands to manage your entries.
You will find detailed informatioon about those commands from the chapter "Main functions". 
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2.5 Saving a file

 
The program is saving your file automatically after each change. So there is no special "Save"
command available. That ensures you will never lose your changes and new information if you forget
to save your file.
 
When saving your file, the program is also making a backup copies of your data. By default (set in
options) the number of old files kept is three. So should something happen to your latest file (like
corruption due to virus), you can always access one of the latest backups. You can read more about
this in Program options / Other chapter.
 
Additionally, in program options you can set additional location where you want to keep your main
file for backup reasons.
 
 

2.6 Opening a file

When you close the program then next time you start it, it is set to open the recent used file
automatically. Of course the master password is required to access the information.
 
To open some other file, you can use "File" menu "Open" command.
 
Also, it is possible to set other file to open at the program startup. You can read more about this in
the Program Options topic.

When opening the file and the password is required, you can also use on-screen keyboard to enter
your database password (available in the Pro version). To bring up on-screen keyboard, click on the
blue keyboard icon at right on the password field.
 
 

2.7 Portability - the program and your file

You can carry your file and the program with you, on the portable devices like USB memory keys,
flash cards, etc. More information about how to put the program and the file to your device, please
read the chapter "Working from portable (USB) devices".
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3 Main functions

3.1 Auto-Type commands

Auto-Type is the command you can use to automatically fill in login prompts. It is available in the
Entry menu and when you open the right click popup menu:

and also in the toolbar:

Using Auto-Type command

The first, and probably the easiest way to use Auto-Type is this: When you are on the web site that
requires you to enter your user name and password, click on the first field that you have to fill in
there (usually user name). When the cursor is blinking on that field, start (or activate) TK8 Safe.
Once your entries are on the screen, just find the appropriate entry and click the Auto-Type button
on the toolbar (or use menu commands). That's it - the web site is activated and your fields are now
filled. 

If you want or need, you can also auto-type only some of the field values. For this opent he Entry
menu (or right click popup menu) and select the single field value you want to send to the last active
page.

Another great way to use Auto-Type: System Wide Hotkey

A very convenient way to use Auto-Type is to hit its hotkey combination (by default CTRL+ALT+A)
whenever you are on the web site that requires your login info. Again, when the cursor is blinking on
the first login field, just press the hotkey on the keyboard. When doing this first time on that page,
TK8 Safe will pop up and asks you to select the entry for that page. Just select it and click Auto-
Type button on the toolbar. Now, whenever you press the hotkey next time on that same web site,
the program already knows which entry was selected last time and fills in the fields with that entry
information automatically. So the only thing you have to do is to press the hotkey.
 
When the entry selection window appears first time you use hotkey on the web site, and you don't
want to remember the connection between the selected entry and the page, uncheck the option
"Remember record selection for Auto-Type Memory" before hitting the Auto-Type button.
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If you want to clear the connection between the entry and the web site, please locate the entry you
need, and edit it. On the Details panel you will see the field "Auto-Type Memory For:". Clear that
field by pressing the "-" button at right of the field and save the entry.

If you have more than one identity (several entries) for some web site, and you want to use the
hotkey method to fill in the page, you can do this (though the program remembers the first entry
filled on the page). Once the connection between one of the entries and the page has been
remembered, find and edit that entry. On the entry Details panel, copy the "Auto-Type Memory"
field value to the clipboard (by selecting the whole field and pressing CTRL+C). Then, edit another
entry you want to use on that page. On the entry Details panel, activate the "Auto-Type Memory"
field, and paste the previously copied page title (with CTRL+V). When you now save the entry, and
press the hotkey next time on that web site, the program asks you which entry from those two you
would like to use currently. The number of entries you can set up for one page in such way is not
limited.

Selecting Auto-Type from system tray menu

When TK8 Safe is in the system tray mode, you can open the tray menu by clicking on the TK8
Safe icon. Selecting Auto-Type from the menu is exactly the same as pressing Auto-Type hotkey on
the web site. So in case you prefer to work with the mouse, you can use that method for convenient
auto filling that remembers the connection between the page and the entry.

 
Customizing Auto-Type templates  (for advanced users)

With TK8 Safe advanced users can also customize the information that is filled in on the login page
(for each entry). By default Auto-Type is filling in the "User ID" and "Password" values. Whet the
program is doing, is that it emulates keyboard key presses, meaning that once the User ID field is
filled, it hits the TAB key (to move to the next field) and then enters the password. So the default
template looks like this: "[USER ID]{TAB}[Password]". 
 
To change the template, you can just edit the "Auto-Type Template" field on entry Details panel.
There you can remove any current fields and keys. To add new key press or fields that should be
sent to the login page, click on the dropdown button at right of the field. From the appearing menu
select what key or field should be.

For example, if the login page has three fields you have to fill: your user name, password, and your
account (domain) name; and additionally you don't' want to hit the Login button each time on that
page yourself, you can create the following template doing everything you need:

 [User ID]{TAB}[Password]{TAB}[Account]{ENTER}
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Known problem
 
If you are using Internet Explorer 7, and Auto-type function fails on your computer, please follow the
directions below to change the setting that prevents Auto-type from working. If Auto-type works, you
don't have to change this setting. This setting is designed for East Asian languages. If you are not
using those languages, you can change it without any worries. You can also restore the original
state at any time.
 

1) Using the Windows Start button, open Control Panel. 
2) Open „Regional and Language Options”. 
3) Click on the „Languages  panel name, to activate that panel. 
4) Click the Details button you see. 
5) Activate the Advanced panel. 
6) Check the option „Turn off advanced text services”. 
7) Click OK. 

Auto-type should work after that. If it still fails, please let us know.
 
 

3.2 Clipboard (Copy) commands

With "copy" commands you can store the information in the Windows clipboard. Once copied there,
you can use it later on some other window (like on some login page field), by using the Paste
commands. To paste the data from clipboard, you can press Ctrl+V on the keyboard. 
 
Clipboard commands are available on the toolbar: 

 

and also in the Entry menu and right click popup menus:

Copy buttons are available also on the entry detail windows, at right of the edit fields:



Main functions

- 18 -

By clicking those copy buttons on the fields, the value of that field is copied to the clipboard. 
 
The clipboard is automatically cleared after a certain period set in program options (by default 5
minutes). That ensures no sensitive information is left to the clipboard for a longer time. If you want,
you can also clear the clipboard manually, by opening the Entry menu and selecting "Clear
clipboard".
 
 

3.3 Run

Run command will execute the link related with currently selected entry, for example a web site or a
file. The appropriate web site is always opened in the new browser window. 

To run the link, you can use the Toolbar button or the Entry menu:

You can associate the link to any entry you have, on the entry details window:

In addition to web sites, you can select files and programs as links. For this you can use the yellow
"open" button at right on the Link field. That allows you to select the file from your computer.
Additionally, advanced users can enter parameters for running programs.
 

System tray and hotkey
 
Run command has also the system wide hotkey available (by default CTRL+ALT+R). When you
press this combination on your keyboard, no matter what other window is currently active, TK8 Safe
will ask you which web site you would like to open.
 
On the system tray mode, when you open TK8 Safe tray menu, you can also select Run command
there. System tray Run command behaves similarly to the hotkey, allowing you to select the entry
which web site you would like to open.
 
 

3.4 Lock

When you leave the desk and/or finish using the file, you can lock it without shutting down the
program. 
 
To lock the file, click the "Lock" button on the toolbar or use the same command from the File
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menu:

 
If the file is locked and you want to unlock it, you can do this the same way you locked the file - just
click on the checked "Lock" button on the toolbar. To unlock and access the information, you will be
asked to enter the database file password, of course.

You do not have to worry if you forget the file open, because it is locked automatically after unused
for some time. The "lock after idle" time can be changed in the program options. By default the file is
locked after 5 minutes unused.

  
 

3.5 Searching & sorting entries

Sorting entries

To sort entries on the list by some column, just click on the column header. A triangle appears
showing the sort order. The second click on the already sorted column header will reverse the
sorting order. So it is possible to sort entries ascending or descending, depending how you would
like to see the list.

It is also possible to sort the entry list by more than one column. To add sorting to additional
columns, hold down the SHIFT key on the keyboard when clicking on the additional column
headers. 

Quick search

To find some of your entries fast, you can just start typing on your keyboard and the closest entry is
located immediately. The locate is made by the column that is currently active: 

Advanced Find

For advanced find dialog, open the Tools menu and select "Find" (or press Ctrl + F on the
keyboard). 

On the appearing window can specify what you want to find (some text, numbers, anything), and
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from which folders. There is no matter where on the field this value is located - at field start, center or
end. If it is there, the Find command will find it. 
 
To start the search, hit the Find button. After that the dialog closed and the matching entry located.
To find the next matching entry, open the Tools menu and select "Find next" or hit F3 on your
keyboard. You can repeat this until the program is telling you there are no more matches left.
 
To start the new search, open the Find dialog again, and specify what you would like to find...
 
 

3.6 Columns and sensitive info

Changing column position and size

Entry list on the main form has default widths and positions for every column. But this can be
changed. To change the size of a column, move the mouse cursor to the end of the column title
(header), until a cursor takes a sizing shape. Then click the left mouse button, hold it down and
move the mouse to the left or right until you get the column width you want. Then release a mouse
button.

To change the position of some column, left click on the column header and hold the mouse button
down. Then move the column to the position you want and release the button.

The column setup for entry lists is remembered, so next time you use TK8 Safe, your
customizations are loaded automatically. 
 
 
Hiding sensitive info

If you do not want to show user names and / or passwords all the time on the entry list, you can
mask them. Masking means that each letter, number and symbol is replaced with * character. It
does not replace the real values on fields, of course, and is used only to show (and protect) sensitive
information. To change field masks, open the "Sensitive Info Mask" submenu from the View menu.
There you can select which fields are masked on the table and which ones are visible. 

If the field is masked, it is masked also on the entry detail window. When you activate some of the
masked fields on the entry detail, the field is unmasked temporarily, though, until you are on that
field. That way you can see what exactly are you editing and typing on the field.
 
 
Adding / removing columns

After installed, TK8 Safe has a default set of columns in the entry list. If you want to add some
columns you see on the entry detail window, but not present on the table, you can do this by
opening the View menu and selecting "Customize columns...". That will open a small customization
window, where you can see all the available columns currently not shown in the entry list. To add
some column to your table, just click on it and hold down the mouse button until you drag it to the
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entry list.

To hide some column, use the same customization window. For hiding just click on the column
header and hold down the mouse button until you drag the column name back to the customization
box. 

After the changes are done, you can close the customization form. The new layout is saved
automatically.
 
 

3.7 Using filters and entry groups

Filters
 
Filters are useful in situations where you have a lot of entries in one folder and you need to see only
those meeting some particular criteria. For example, if you want to see passwords expiring on
March next year. Those entries not matching the filter criteria are hidden until you remove the filter.
 
To set a filter to the entry list, you can use filter dropdown button at right on the column header.
Once clicked, you can select which value should be in common on the entries you want to see:

To create more flexible filter, click on the "(Custom...)" selection. After that the custom filter dialog
appears with intuitive selections and descriptions.  You can there select the condition (like equal,
greater than, like, etc..) and type the value. It allows you to create filters where, for example, you will
seen only entries containing the "aa" in the field.

After the filter is selected or custom filter set, you can see the condition at the bottom of your entry
table: 

To remove (close) the filter, click on the red "X" button on the filter conditions panel. 

Grouping entries

In addition to having entries divided to different folders, you can also use grouping features in TK8
Safe. Grouping is a way to display entries in the entry list. To enable grouping feature, please check
the "Show Grouping Bar" option in the View menu. When it is checked, you will see a dark grey
panel (grouping box) at the top of your entry list. 
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To group your entries, drag some column header (for example description, if you are using that field)
to the grouping box area. The information is divided to groups, based on the values found in the field.
You can extract and collapse groups by using the "+" and "-" buttons on the group titles (on the
entry list). To remove grouping, please drag the column header back to the entry list. To hide the
grouping box, use the View menu and uncheck the "Show Grouping Bar" option.
 
 

3.8 Undo and Recycle Bin

If you have deleted some entry by accident, or changed the value you didn't want to change, you can
undo your past actions. For this, open the File menu and select Undo. The program will ask if you
are sure about taking back your action or not. Even if you close the program meanwhile, the program
remembers what you did last time and allows you to undo that days and months later.
 
Additionally, the program has Recycle Bin, where you can see all the deleted entries:
 

When you delete entries, they are not completely removed, but saved in the Recycle Bin. Just like
when you delete your files in Windows. If you want to undelete some of your records, you can open
the Recycle Bin, and select the entry you need to restore. Once selected, click on the "Undelete"
button on the toolbar.
 
To completely remove the record, you can open the Recycle Bin and click "Delete selected" or
"Empty Recycle Bin" buttons. Once you empty the Recycle Bin, your entries are permanently
deleted and there is no way you could get them back.
 
 



TK8 Safe User's Guide

- 23 -

4 Tools and additional functions

4.1 System tray mode

TK8 Safe has possibility to run in the System tray mode. It means the program is accessible by
using (clicking) on its system tray icon, near the system clock:

You can go to system tray mode by using the Tools menu command, or by pressing F12 on your
keyboard. Also, if set in options, TK8 Safe can start in the tray mode, or go there automatically
when you lock the file or minimize the program.
 
When you click on TK8 Safe tray icon, the menu appears from where you can use Auto-Type and
Run commands. Also you can lock and unlock the program.
 
To restore main window mode (for example to add or edit entries), open the system tray menu and
select "Restore". Also, you can press TK8 Safe system wide hotkey on your keyboard (by default
CTRL+ALT+S) from any window to bring up the program.
 
 

4.2 Password bar mode

Password Bar is a small window to work with your passwords. It is always on top, so whatever other
Windows program you are using, TK8 Safe password bar is visible on top of it. To switch TK8 Safe
to the Password Bar mode, click F11 on your keyboard or use Tools menu on the Main window.

In the Password Bar mode you can access all login, card and serial number entries. 

You can also change the position of this small window. For this, click on the Password bar and hold
the button down until you move it to the place you like. After the position is ok, release the mouse
button. 

Using password bar

When you need some password or user name, click on the password bar white edit box and start
typing the account name. The dropdown menu appears where you can see the closest match. Click
on the appropriate entry once you see it. After clicked, the entry name is seen on the edit box. 
 
If you did a typing mistake, you can use Backspace button on your keyboard to "delete" letters you
typed. 
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Another way to select the required entry is to click on the dropdown button directly, without typing
the account name.

By clicking the "..." button at right you can access the commands menu. There you can select to
copy or auto fill field values of selected entry, add new or edit current entries. You can also lock the
file and switch back to the main window mode. 
 
 

4.3 Password generator

Password generator is a small utility included to TK8 Safe to generate new secure passwords. With
a click of a mouse you can generate new random passwords. Random passwords are good because
they are impossible to guess.

When you are adding new entries, password generator always fills in the password field with a
random password. This automatic behaviour can be turned off when you open the Tools menu,
Program Options, and from the "Other" panel check the option box "Turn off automatic password
generation when adding new entries".
 
If you would like to change the password with a new random password, you can just replace it with
your own password, or start the generator to create a new password. To start the password
generator, click on the icon at right on the password field:

If you want to generate some password unrelated to the entry, you can open password generator
also from the main window, using the Tools menu.

Soon the password generator is opened, a new random password is created automatically. If you
want to create a new one, you can do this by clicking on the "Generate" button. You can also set
the length and what type of characters it should contain (like numbers, special characters, upper
and/or lower cases etc).
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In the Professional version the program has an additional edit field "Template" available on Password
Generator window:

If the template option is checked, the program will generate a new password based on the
characters found on this field. The following character "translation" will apply:

· A - random upper case alphabetic (A to Z)
· a - random lower case alphabetic (a to z)
· N - random numeric value (0 to 9)
· X - random alpha-numeric value (A to Z, a to z, or 0 to 9)
· ! - random character 

 
If you want to exclude some characters from appearing in your password(s), enter that character to
the Exclude edit box. 
 
The generated password can be copied to clipboard - for this click on the clipboard button at right on
the password edit box. When the generator is started from the entry form, the password can also be
applied to the entry. For this click on the "Apply" button.
 
To close password generator click on the "Close" button.
 
 

4.4 Favorites, File Summary

Favorites
 
If you have a lot of entries in some particular folder, but are using only few of them more often, you
can use Favorites. Favorites is a list of your entries you have marked as favorite entries. 
 
On the entry list, to mark the selected entry as a favorite entry, open the Favorite menu, and select
"Add to favorites".

To see your list of favorites, click on the "Favorites" tab name at the bottom of your screen, or open
the View menu and select Favorites. You can use all the normal entry commands. The only
difference is that the list is shorter, and contains only records you have marked as favorite entries. 
 
To remove some entry from the favorites list, select it there, and from the Favorites menu select
"Remove ...". 
 
To switch back to the normal mode, open the View menu and select Entries.
 
If you are not using the Favorites functionality, you can hide the Favorites tab at the bottom of your
screen and the menu item. To hide, open the Program Options, Appearance panel, and uncheck the
Favorite functionality options.
  
 



Tools and additional functions

- 26 -

File Summary
 
File summary is the function that will tell you how big is your file in size, how many folders and
entries you have (total and by folders). Additionally, it will tell you how many entries you have in the
Recycle Bin. 
 
You can switch to the Summary view from the View menu. To switch back to the normal mode, open
the View menu again, and select Entries.
 
 

4.5 Importing, exporting and printing

Importing entries

Import function will help you when you have a list of password entries outside of TK8 Safe and you
would like to see them inside your file. 

To import external file content to your TK8 Safe password database file, the impost file has to be in
the TAB delimited text file format. If you do not know anything about file formats, you can try to open
the file in Microsoft Excel for example. Once your content is seen there, use the "Save As"
command and select the file type "Text file (tab delimited)" before saving. Once you have saved the
file that way, you can close it. 
 

Please note - the first row in the import file has to contain column (field) names.
 
Once the import file is ready, you can start the import. Before, though, you have to decide to which
folder you would like to add those imported entries. You can create a new folder for this, or select
some of your current folders. The folder currently selected is the folder where the entries are added
from the import file.

Now, to start importing, open the File menu and select Import. After you select which file to import,
import details window appears. There you can see the columns and information found in the file. 
 
Next you have to set destination fields for the columns you want to import. To do this, please click
on each column header and select the field where you want to save that information. 

Once columns are set, click the "Import" button. When done, the Import window is automatically
closed, and you should see the entries that were imported.
 
 
Exporting and printing your entries 

In case you need to use your sensitive information outside of TK8 Safe, in some other file format, or
a "hard copy" on paper, you can use the Exporting command for this. Please be careful with
exported files as they are not protected and can be opened by other users having access to your
computer or to the exported file.

Before you start exporting, please select the folder from where you want to export the entries. Once
the folder is selected, open File menu to select "Print and Export" from there.
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On the appearing window you can select what you would like to export - only the selected entry or
all entries from the selected folder. Next you can select the output format:

· Print to printer
· MS Excel (XLS)
· Text file (tab delimited)
· HTML file
· XML file

After the format is selected, you can start by clicking the Export button. When you selected the file
format, you will be asked for a file name used for your exported entries. When the "Print to printer"
was selected, the program will start printing to the default printer you have.
  
 

4.6 Send to

From the File menu, "Send to" submenu commands are available. It has three options:

1. Portable device

By selecting this option you can port the program and your file to the portable devices like
USB Memory sticks, flash cards, external hard drives, etc.  Once sent there, you can start
using the program from the portable device directly, in addition to your local copy. That way
you can always carry the program and the file with you.

2. Desktop shortcut

By using the Desktop Shortcut option, a new icon is created to your desktop, pointing to your
file. It allows you to start the program and open the file automatically (of course, the password
is required). If you have working with only one file, that option has no much use, as the recent
used file (your only database file) is opened anyway. But if you have several files you work
with, you can create shortcuts to your desktop for all of them. And instead of starting the
program and selecting the file to work with, you can just double-click on the appropriate
desktop shortcut. 

3. Mail attachment

If you need to send the file as mail attachment (for example as a backup copy to your own
mail account), you can do this by selecting this option from the "Send to" menu. This
command will create a new email with your default mail program, and will attach it to there, so
you could send it easily.
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4.7 Working from portable (USB) devices

When using TK8 Safe, you can take the entire program and your file with you on the portable device
(like USB memory keys, flash cards, external hard drives, etc.). 

First, still, you need that the program is installed to your local computer. Once you are in need to
put the program to the portable device, run the program (from your local computer) and open the File
menu. Under the "Send to" submenu select "Portable device". The appearing window allows you to
specify what files you would like to port to your device. 
 
You have the following options available:

1. Currently open database file
2. The program itself
3. Help file
4. Registration info

 
For example, if you want to keep the space acquired by the program minimal, you can left out the
help file and thus save some space on the device.
 
Registration info option is available only when you already have the program registered. When the
registration info is ported to the device, and you run the program from there, it is running in the
registered mode for the time you work on that computer. So you can use the full functionality without
any limitations.
 
You also have an option to select the exact target folder on the device you prefer to store the
program and your file. For this click the Select button. Additionally, when the option "Put all file to
TK8 Safe sub folder" is checked, additional folder is created (if it doesn't exist yet) under to the
selected location.
 
After you click the "Start" button, your data is in two locations (your local computer AND the
portable device). So you should decide from which location you start working with your data and
which file you keep as a secondary file. The problem might arise when you add one entry to the file
on the portable device, and the other entry to your local file. In such situations the synchronization
feature (available in the Professional version) will help, though, to keep both files the same. 
 
If you prefer to keep the entire and latest information on the portable device, you can just start using
the program from that location all the time and in such case you have no need to synchronize files
nor think about which file to use. 
  
If you are using the local copy in most cases, and the file is in on the portable device just for case
you need it sometimes, you might be in need to refresh that data on the device. For this, just open
up the "Send to portable device" window again, and re-send the data to the device. The old data is
then overwritten with your fresh, local information.
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4.8 Keyboard shortcuts

By default, you can use following key shortcuts with TK8 Safe:

System wide keys

Ctrl + Alt + S Hot key to activate TK8 Safe whatever other program you are
currently running

Ctrl + Alt + A Hot key to call Auto-type command for filling login information on the
currently active page

Ctrl + Alt + R Hot key to select and launch the link related to some entry

Main window

Ctrl + N To create a new TK8 Safe file
Ctrl + O To open TK8 Safe password database files
Ctrl + P To start sending the program and your file to the portable media
Ctrl + Z To undo the recent action
Ctrl + L To lock or unlock the file

Ins Adds a new entry to your file
Del Deletes the selected entry
 
Ctrl + R To Run the link related with selected entry
Ctrl + A To Auto-type the previously active page with selected entry

information
Ctrl + U Copy user name of selected entry to the clipboard
Ctrl + C Copy the password of selected entry to the clipboard
Shift + Del Clears the clipboard

Ctrl + M Calls for "Mail entry on template" command.
 
Ctrl + F / F3 Advanced Find dialog / Find next
Ctrl + H Hide (mask) password values

F12 Go to system tray mode
F11 Go to password bar mode

Ctrl + G Starts password generator
Ctrl + W Starts Web browser

F1 Press to open the help file
 
 
Other standard key shortcuts:

Up, Down, Left, Right To navigate on the entry list
Enter To open entry forms and to confirm selections
Esc To cancel the changes and close forms
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5 Features in the Professional version

5.1 Multi-user support

 
Professional version allows you to connect multiple users to the same database at the same time.
That includes multiple sessions by the same user (for example if the same file is opened with two
program instances). All users will get the full (not only a read-only) access to the file. 
 
When one user changes the database, others will see the change immediately (after they have
changed the folder, or done some changes in the database). 
 
The program has built in record level locking, protecting that different users can overwrite others
changes without knowing. If both users are changing the entry, then the first one who saves, will
succeed. The other user, should he decide to save the changes, will get the error message saying
that during the time they entered the change, the record has been modified already and thus the
change cannot be made. Once the database is refreshed, and the second user will see the change
that the first user did, but still wants to change the entry, he can then open the entry window again
to make and save the change.
  
  

5.2 User permissions

 
Built in user permission system allows you to create separate user accounts for your file and restrict
access for those users. You can have folder, entry and feature based restrictions.
 
To set up and manage users, please open File properties from the File menu. To add, edit or delete
users, use the "Users & Permissions" panel. On the user list you will see the user account name
and the last login. 
 
When adding or editing user account, the user account details window is on the screen. On its
"User information" panel you can enter the account a name and set the password. Additionally you
can set a hint to recall the password if the user should forget it.
 
On "Access to information" panel you can restrict the possibility to access some data. For each
entry type (like logins, cards, serial numbers) you can set different permissions. You can show the
user all entries, or only those they have created. You can also enable or disable adding new entries.
When setting editing and deleting permissions, you can select if the user can delete/edit all entries,
those created by this user only, or is the feature completely disabled. 
 
To limit access to some particular folder(s) only, you can check those folders on the right aligned
folders list box. 
 
The "Maintenance & Usage" panel allows you to set which features the user can access. By default
all features are enabled. To disable some (for example auto-typing), you can uncheck those check
boxes.
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5.3 File Synchronization

 
File Synchronization feature available in the TK8 Safe Professional version will help you to merge
information from two files into one database. 
 
Though the best strategy to use the "latest version" of your data is to use the database directly the
USB drive (memory stick), this option is not always available. If you change the database in one
computer, and then another, the data you have on both files is different. To "merge" the changes
from those two files, you can use File Synchronization. 
 
Let's say you have a database file A in your laptop and a database file B on your desktop. If you are
behind a desktop, you can Synchronize your file with the laptop database file, to import all new and
edited entries from the file A. 

You should know that not all changes are synchronized (like deleted entry information). If you have
deleted an entry from the file A, that entry is not deleted automatically in file B while the databases
are synchronized. This is both for security reasons and to avoid logical conflicts. For example, if the
program finds an entry from the File B that does not exist in file A, the program can't decide if it is a
new record added to your desktop file, or is a record deleted from the laptop. In both situations the
record exists in one file but not in another. That is why records are not deleted automatically during
the synchronization. 
  
Also, the synchronization does not replace your original source file with the synchronized one.
Again, this is for security reasons, meaning you can access the unchanged source data until you
want. After you have synchronized the database on your desktop, and want to access the same
database on your laptop, you have to copy the database file back to the laptop manually (or use File
menu, Save As command). You can also keep using the old laptop database until you want, and
synchronize it from time to time with your desktop database. 
 
To start synchronization, please open File menu and select "Synchronize...". On the appearing
window you can select the file from where you want to import changed and new entries. Of course,
you have to enter the password for that database. Once the file is selected and password entered,
you can click the Start button, which will start the synchronization process. During the
synchronization you will see the progress until it's done. After completed, you can close the
synchronization window and can immediately see the changes in your database (if there were some
changes).
 
 

5.4 Login Groups

 
You can form groups from your entries. This simplifies launching several entries with one mouse
click. 
 
For example if you would like to check out some statistics on different web sites each morning, you
can select the group and run it. For this you can have "Marketing" group for example, and to open
each web site entry of that group, click the "Run Group" button on the toolbar. Additionally, you can
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access all other entry commands (like copy and auto-type) for the selected group entry, if you want.
For the future, we are also planning the "Auto-Type Group" feature, which would automatically fill in
the login fields on all pages once they are loaded. 
  
To see your groups and the entries they contain, click on the "Group" tab name at the bottom of
your screen, or open the View menu and select Groups. To manage your groups, you can use the
Group menu. Under the Organize submenu you can add, edit and delete groups. To switch back to
the normal mode, open the View menu and select Entries.
 
To add some entry to the group, select that entry in the normal entries view mode, and open the
Group menu. From the "Add" submenu you can select your group name where that entry should
belong to. If you want, you can add one entry to several different groups. 
 
To remove some entry from the group, open the groups view mode, and select the entry you want to
remove from that group. Then open up the Group menu and select "Remove from Group". 
 
If you are not using the Groups functionality, you can hide the Groups tab at the bottom of your
screen and the menu item. To hide, open the Program Options, Appearance panel, and uncheck the
Groups functionality options.
  
 

5.5 History log

 
History log is the place in the program where you can see every entry change made in your file. that
includes added entries, changed field values and deleted entries. It can be good in multi-user
environments, to see what has happened to some particular entry, or what changes have been made
by some particular users. 
  
For this feature to work, please open File properties, Settings panel and see how many changes is
set there to keep. Additionally you can specify there which changes you would like to keep in the
history log.
 
When the history feature is active, you can open the File menu and select "History Log" to open the
Window. On the appearing window you will see the table with changes. Similar to the main window
table interface, you can there sort, filter, and locate entries. 
 
You also have the option to undo some particular action, not only the latest action like with File
menu Undo command. You can just activate the row with the change and click on the Undo button
on the toolbar to take back that change.
 
If you don't want to delete some or all actions from the history log, you can do so by using the
"Delete" or "Delete All Visible" buttons on the toolbar. If your table has a filter (for example to see
entries changed by one particular user only), the "Delete All Visible" button will indeed delete only
those entries you see. When you clear the filter later on, and there are other records in the history
log with other parameters, they will stay to the history log.
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5.6 Templates

 
In case you want to add specific and the same additional field to a lot of entries, you can use
templates for this. With templates, you can add a pre-set number of fields to the entry, with the
names and default values as you have specified earlier. 
 
To manage template, open the File menu and select "Organize Templates". There you can add new,
edit and delete current templates. When adding or editing template, you can name it and specify
which fields it should have. As you can see, you can also change the order of fields with up and
down toolbar buttons. Additionally, you can set the option "Auto load" for a template, indicating that
you want to add fields and values from this template automatically to every entry that is added in the
program.
 
Now, once you have a template or some of them, you can start loading them to your entries. When
you open entry window (add new entry or edit some current entry), then on the "Additional fields"
panel you should see the "Templates" button. When you click it, the menu appears from where you
can select the template to load to the current entry. Once selected, all the fields and default values
are added to your entry. If your entry already contains additional fields, the program will ask if you
would like to remove old values or keep them.
 
 

5.7 E-mailing entry information

You can access e-mail commands by using the Mail submenu on Entry menu.
 
Mailing login / entry info

Mailing login or entry info starts the default e-mail program and fills the mail body with information of
selected entry. Use this command if you need to send the login (or the full entry) data to someone. If
you choose "Mail login info", just account name, user id and password is used on the e-mail. "Mail
entry info" will add also additional fields like link, description, notes etc. if not empty.

Mailing on template (Ctrl + M)

By using this command you can send customized e-mails, containing selected entry information
inside the e-mail text. After the command is executed, you can select which template file you would
like to use. You also have the possibility to pre-set the template filename in the program options, so
you would not have to select the file name each time. 

Once executed, e-mail is created in your default email program based on the template. you just have
to hit the "Send" button to confirm the email sending
 
Template is a normal text file (created with notepad, for example). The text can contain keys, which
will be replaced with entry information. Supported keys for the templates are:

--------- LOGINS ----------

<<ACCOUNT>>

<<USERID>>

-------- CARDS -------------

<<NAME>>

<<HOLDER>>

-------- SERIALS -------------

<<APPLICATION>>

<<VERSION>>
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<<PASSWORD>>

<<LINK>>

<<DESCRIPTION>>

<<NOTES>>

<<EXPIRES>>

<<CUSTOM:NAME>>

<<NUMBER>>

<<SECURITYCODE>>

<<VALID>>

<<PASSWORD>>

<<NOTES>>

<<REGISTEREDTO>>

<<SERIALNUMBER>>

<<CERTIFICATE>>

<<VENDOR>>

<<WEBSITE>>

<<EXPIRES>>

<<NOTES>>

<<ORDERDATE>>

<<ORDERNUMBER>>

<<ORDERPRICE>>

<<ORDERCURRENCY>>

<<ORDERDETAILS>>
  

The available fields (keys) and sample template files are included to the TK8 Safe program folder,
under the Templates folder. 
 
 

5.8 Encrypting file

In addition to keep sensitive information, TK8 Safe has built in module for quick file encryption. If the
file is encrypted, the information in it is not readable before someone decrypts the file. For
decryption, the password is required that was used when the file was encrypted. Without knowing
the password, the file remains unreadable forever.
 
On file encryptions and decryptions the secure AES (Rijandael) 128-bit algorithm is used.
 
To encrypt a file, open Tools menu and select "Encrypt file" from the File operations submenu. 

On the file encryption window please select the file you would like to encrypt. To do this, click on the
yellow folder button at right on the edit box. Once selected, you have to select also the destination
file name.
 
Before you can start encrypting the file, you have to enter the password and retype it to the "Confirm
password" edit box (to prevent typing mistakes). 

When the password is entered, you can start encryption by clicking on the "Encrypt" button or close
the window.
 
Please note that you can decrypt the file only with TK8 Safe, knowing the password that was used
for this encryption.
 
 

5.9 Decrypting file

In addition to keep sensitive information, TK8 Safe has also built in module for quick file decryption. 

You can decrypt files encrypted only with TK8 Safe. Also, password that was used on encrypting
the file is required for decryption.
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To open Decryption tool, open Tools menu on the main window and select "Decrypt file" from the
File operations submenu. 

On the decryption window please select the source file you would like to decrypt. For this you can
click on the button at right on the field. Once the source is selected, you have to select the
destination file name also. You can do this also with the help of a button. 

Next you are required to enter the password, and once that is done, you can execute the action by
clicking the "Decrypt" button.
 
 

5.10 Secure delete

Secure Delete feature is almost the same as deleting the files from your computer normally, except
there is no possibility to recover those files later on.

Normally when you delete a file you can recover it later by using Recycle Bin. Or, if the file is deleted
from there also, it is still in the hard drive 'out there' and can be recovered with special software.
 
Secure Delete replaces the information inside the file with random data and deletes the file after that.
Once overwritten (and done so several times) there is no sense to restore such file any more by
someone, as it does not contain original content any more.
 
To open Secure Delete, open the Tools menu and select it from the File Operations submenu. Once
the window appears, you can select the file and press the "Delete" button. For security reasons you
are also asked to confirm the action before the deletion is executed. 
 
To close this window without destroying the selected file, please click on the 'Close' button or hit
'Esc' on your keyboard.
 
WARNING: ONCE THE FILE IS DESTROYED, YOU CAN NOT ACCESS OR RECOVER THE FILE
IN NO WAY ANYMORE
 
 

6 Program Options

6.1 General

On the General tab it is possible to set how TK8 Safe should react on basic situations.

"Lock to system tray" option, if checked, will minimize the program to system tray mode when you
lock the file.

With "Minimize to system tray" option checked, the program will go to the system tray area when
minimized. 

If the option "When returning from system tray, always ask the password" is checked, then no
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matter if your file is currently locked or not, when you return from the system tray area, you have to
know the file password in order to access the program.
 
By default, when you return from system tray area, the file locking state remains as it is. It means
that when your file is locked, it stay's locked, and if it is open, you will see your entries. But if you
check the option "When returning from system tray and the file is locked, ask the password", your
file password is asked automatically when returning from system tray. And once entered, the lock is
removed. In such case you don't have to unlock the file manually to access entries.
  
"Close to system tray" option prevents the program from closing when checked. Instead of closing,
the program will be minimized to system tray mode. It is good in case you want to keep the file and
the program open but afraid you will still close it by "accident". This option is ignored on Windows
shutdown and in case you use File menu Exit command. 

If you are using clipboard commands you might want to clear the clipboard on program exit. For this
you can check the option "Clear clipboard on program exit" and it will ensure no sensitive information
is left in to your clipboard after the program is closed.
 
Additionally, you can specify the period after which the clipboard is always cleared. By default your
clipboard is cleared after every 5 minutes, no matter is the program used or not. 
 
If you do not use the program for some time, it goes to idle mode. On going to idle mode TK8 Safe
can automatically lock your file or close itself. By default the program remains idle after 5 minutes
unused, but you can specify this on the current panel. Additionally, you can what the program
should do once idle (by default it will lock your file).
 
If you want to restore default program settings, please click on the Default button at left bottom of
the screen. That will reset the settings (applied to all Options panels).
 
 

6.2 Startup

On the startup panel you can set different actions to be done on program startup.

At first you can specify which file the program should open. By default, the last used file is opened
on program startup. If you want to open a specific file each time, you can select this option and
select the file. You can also disable auto opening by selecting "Do not open any file on program
startup". Of course, when the file is opened, the master password is always required to open it.

The program can be started automatically on the Windows startup. To do this, you have to check
the option "Run the program on Windows startup".

With the option "Expand folders" you can set do you want to expand folders in your file on startup or
you would prefer to keep them collapsed.

"Show splash screen" option, if checked, will show waiting screen during the program startup.

On the startup panel you can also select the program state on startup. By default it is started as
you left it last time - the size, position, etc. is remembered for the next time. Additionally, you can
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select to open the program Minimized, Maximized, or in the System tray and Password bar mode.
 
  

6.3 Keys / Auto-Type

System wide hot keys can be used to call different TK8 Safe commands from other programs. TK8
Safe has three system wide key combinations:

· System wide hotkey (default "Ctrl + Alt + S")

System wide hot key will bring up TK8 Safe in case some other program is currently active. If
the program is already active, and the option "Lock the program with hot key if active" is set,
the file will be locked.

· System wide Auto-Type (default "Ctrl + Alt + A")

If you need to auto type some login information, you can press the Auto-Type hot key in your
keyboard. After pressed, you will be asked what entry you would like to use on filling (if you
are on that page first time). The connection with that window and the selected entry can be
remembered, so next time you press auto-type hot key on that same page, right entry is
located automatically and login prompts filled immediately. This is called "Auto-Type
Memory". If you want to disable remembering page connections, you can do this by checking
th eoption "Disable Auto-Type Memory for system wide hotkey". If disabled, autofill system
wide hotkey will fill the fields with the data of currently selected entry (from Main window).

· System wide Run (default "Ctrl + Alt + R")

Run hot key will open the list of entries and allows you to select which entry link you would
like to launch.

In case the file is locked at the moment auto-type or run hot key is pressed, you have to enter the
password of your database file at first.

To change hot keys, click on the edit box and press desired key combination.  

If you want to submit the auto-typed information automatically after the login prompt is filled, you can
check the option "Send additional {ENTER} key press after Auto-Type is complete". 
 
Please note: If some other program is using the same key combination defined in TK8 Safe, the hot
key may not work. In case the hot key is not working, please change it. When changing, TK8 Safe
does not allow you to set hot keys already active in your system.
 
On this page you will also find the option to automatically lock your file after you have auto-typed the
login prompt.
 
You can also set a delay time between the key strokes sent to the application or the web page.
Some web pages do not like when the data is entered too fast. In such cases, you can increase the
delay length, so it seems to the page that a real human would type the info in.
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6.4 Appearance

On the "Appearance" you can change the look of TK8 Safe.

First, if you want, you can change row colors of your entry list. To change some of the colors, just
click on the appropriate edit box and select the color. Additionally, you can specify the color for
expired entries. If you want to see entries which will expire soon in different color, you can set the
expiration warning period in days and then the color used to display entries that are about to expire.
 
By default you will see the tab on the bottom of main window entry list to switch between Entries,
Favorites, and Groups. To hide this it, uncheck the "Show the bottom tab ... " option.
 
If you don't want to see the Favorites main menu item, you can hide it by unchecking the option
"Show Favorites menu"
 
If you don't want to see the Groups main menu item, you can hide it by unchecking the option
"Show Groups menu"

With TK8 Safe you have a choice of 4 different toolbar styles: XP, Office 11, Standard, Flat. By
default, the program uses the XP style.

Check the "Gray scale buttons" option if you do not want to see button colors. Also text position on
the buttons can be changed or hidden. 

By default the buttons are in the medium size (24 pixels), but this can be changed to large (32
pixels) or to small (16 pixels).

Additionally you can specify where you would like to see the text on the button, or if you would like
to hide the text completely.

To customize the buttons you see on the toolbars, right-click with your mouse on the toolbar on
the main window and select 'Customize'. After that a standard toolbar customization window will
open where you can create new toolbar groups and select / remove buttons on the toolbar groups
(by dragging them with mouse).
 
 

6.5 Language

On this panel, you can select the program language you want to use in TK8 Safe. 

Language support is flexible and allows you to translate the program to any other language that is
not currently present in the list. Additionally, you can fix the texts in the current translation if you
want to. 

To fix or update the translation, click on the "Edit selected" button. That will bring up the translation
window. 
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In case your language is not listed in the selection and you would prefer to use the translated
program, you can translate it yourself. Translating is easy and takes only few hours. To add a new
language, click on the "Create a new translation" button and enter the language name on the
appearing window. After entered, the translation window will appear.
 
When you edit the translation (or are creating a new one), a translation window appears. First step
there is to select the Window from the left panel you would like to translate (section number 1) .
After selected, you can select the value on the "Original" panel (section 2) and translate the value at
the bottom of the screen (section 3). When the sentence or word is translated, hit the Save button
and select another one you want to translate. You can also hit the Enter key on your keyboard,
which will save the translation and selects the next phrase for translation.
 
If you translate the program to your local language, please send the translation to us also, so we
could include it with next releases. To create a backup file from your translation, click on the "Back
up to desktop". After that a small file is created right to your desktop. To send it to us, attach it to
the email and send to support@tk8.com . If you translate the program to the new language, we will
give you a free license key with lifetime updates.
  
 

6.6 Other

 
By default, all the changes you do in the file, will be saved automatically. This feature can not be
turned off since the version 3 due to security reasons. 

It is possible to copy your file to the additional location (folder) after it is closed. To activate this
feature, check the option and select the target folder. To select the folder, click on the button at right
on the edit box.

By default TK8 Safe will keep 3 backups from your file. So if something happens to your file and it is
corrupted (like after virus attack), or you delete the whole file by accident, you can access the latest
backup. Automated backups are with the same name, but instead of TKS extension they have
extensions "backup1", "backup2", etc. You can open such files directly with TK8 Safe, or, you can
remove the "backup" from their name if you want to, before opening them.

If for some reason you want to disable auto backups, just set the field value to 0. To keep more
backup, enter the number of backups you would like to keep from your file.
 
Together with other things, you can set on this panel what action you would like to perform by
double clicking on the entry list table. By default double click will open the entry detail form for
editing, but this can be changed. For example double click can launch the web site related with
entry, perform Auto-Type, copy user name or password, etc. 
 
Another option on this panel is "Turn off automatic password generation when adding new entries".
By default, the program will generate a new random password every time you add a new entry. If you
don't want to use the default generated password, and prefer the empty field, you can check this
option.
 
Professional version of TK8 Safe has the ability to email login information. This can also be done on
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templates. In this panel you can select the template files used to send out emails containing entry
data.
 
 

7 Ordering and registration

7.1 Why to order

TK8 Safe is shareware. Shareware is try-before-you-buy software. Unlike retail software that you buy
in stores, with shareware you can try the software out and see how good it is before you buy it! If
you like it, you can order the full version. It's a great way to buy software, plus we offer the 30-day
money-back guarantee!

7 Great Reasons To Order TK8 Safe:
· Only $29.95 (US). Limited time offer: Only $19.95 (US)
· 60-day money-back guarantee
· No more trial period limitations and evaluation screens
· Free updates and upgrades for a whole year!
· Unlimited high-priority support free for lifetime
· License Key emailed to you immediately
· A warm fuzzy feeling that you did the right thing

 
Go for TK8 Safe Professional, and get more:

· All the features and benefits of TK8 Safe standard version
· Impressive set of additional features
· Only $39.95 (US). Limited time offer: Only $29.95 (US)
· Upgrades and updates for 2 years

 
 
Comparison of Standard and Professional Version:
 
Professional verison has all the features of Standard verison, plus:

· Possibility to use different encryption alorithms (instead of default AES 128)
· Synchronization
· Login Groups
· Access to the file with multiple sessions (same-time multiuser access).
· Option to email login info (on different templates, if required)
· History log feature where you can see every change made in the database
· Templates to load default field names (and values) to login entry additional fields
· File Operations module to encrypt and decrypt external files. Secure Delete function for external

files
· User permission system (access restrictions to different folders and feature based restrictions)
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7.2 Prices

Prices are subject to change. Latest prices are listed in our homepage http://www.tk8.com. 

Licenses do not include a disk with the software. By purchasing a license, you will get a serial
number to register your copy (which sets you free of the 30-day trial limitation).

TK8 Safe license prices:

Standard version:
Number of Users Price per User Limited time offer
1 User $29.95 $19.95
2-4 Users $24.95 $16.95
5-9 Users $22.45 $14.95
10-24 Users $19.95 $12.95
25-49 Users $16.45 $10.95
50-99 Users $14.95 $9.95
100-199 Users $13.45 $8.95
200+ Users $11.95 $7.95
 
Professional version:
Number of Users Price per User Limited time offer
1 User $39.95 $29.95
2-4 Users $33.95 $24.95
5-9 Users $29.95 $22.45
10-24 Users $25.95 $19.95
25-49 Users $21.95 $16.45
50-99 Users $19.95 $14.95
100-199 Users $17.95 $13.45
200+ Users $15.95 $11.95
 
 
Comparison of Standard and Professional Version:
 
Professional version has all the features of Standard version, plus:

· Possibility to use different encryption alorithms (instead of default AES 128)
· Synchronization (coming soon)
· Login Groups
· Access to the file with multiple sessions (same-time multiuser access).
· Option to email login info (on different templates, if required)
· History log feature where you can see every change made in the database
· Templates to load default field names (and values) to login entry additional fields
· File Operations module to encrypt and decrypt external files. Secure Delete function for external

files
· User permission system (access restrictions to different folders and feature based restrictions)
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7.3 How to buy

The fastest and easiest way is to order online, using a credit card. All orders will be processed
securely in real time by SWREG (Digital River Ltd). SWREG is one of the most known processing
companies in the Internet. To offer you the best and risk-free service, we signed contract with
SWREG to process our orders.

In case you do not want to submit your credit card information online, you may use also a check,
phone, fax or purchase order. We will accept also direct wire transfers.

All our software includes unconditional 60-day money-back guarantee. If you aren't happy with
your purchase for any reason, just let us know, and you'll receive a prompt, full refund. No questions
asked.

To start ordering, please visit our homepage http://www.tk8.com 
 
 

7.4 Entering License Key

Soon your order is placed, you will receive order confirmation (receipt) together with registration
information. By entering and saving this info on the registration window, your copy will be free of the
trial period limitations. 
 
The registration information contains License Owner Name and the License Key. To enter them,
please click on the "Enter License Key" link on the trial version startup screen, or use Help menu.
 
On the registration window, please enter the name and the key exactly (case sensitive) as they are
typed in the order confirmation e-mail you received. After entered, you can confirm the registration by
clicking the "Save" button. 
 
After the info is saved, the copy will be registered. Please restart the program so the registration
would take the effect.
 
 

8 Getting help and support

Inside the program, when you press F1 on your keyboard, you can read the help file. The help file is
also available in our homepage and in the pdf format ready for printing.
 
If you have any questions or suggestions regarding TK8 Safe, your e-mail is always welcome.

If you have any problems with the program, please include the following information when contacting
us:

·  Is the problem (error) reproducible? If so, then how?
·  What version of program are you running (to see this, use About in the Help menu)?
·  What version of Windows you are running (Windows XP, Windows 98, Windows NT 4.0, etc.)?
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·  If you see a dialog box with error message on the screen then what is the full text on that
dialog box.

Official homepage: 
http://www.tk8.com 

Support e-mail:
support@tk8.com 
 
Support form online:
http://www.tk8.com/safe/support.asp 

General / Sales contact:
info@tk8.com 
 
Postal address:
TK8 Software,
B & M Konsultatsioonid Inc,
Liiva 54-a, Noo
61601 Tartumaa,
Estonia, EU.
 
Phone number for Sales:
+1 (310)-817-6515 (this phone number is for sales and business calls only. To get technical support,
please e-mail us or fill the online support form)
 
 

9 Uninstalling

Removing TK8 Safe from your system is easy. 

Before starting removal close the help file and TK8 Safe program. 
 
Then open the Control Panel, Add/Remove Programs window. Look for TK8 Safe in the list and
select it. Click on the "Add/Remove" button to start removing the application and follow the
instructions on the screen.
 
Uninstalling deletes only the files saved to your hard drive on installation. No password or additional
files will be deleted. To delete TK8 Safe password files you have created, you have to do this
manually.
 
 

http://www.tk8.com
mailto:support@tk8.com
http://www.tk8.com/safe/support.asp
mailto:info@tk8.com
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10 License agreement

TK8 SAFE
LICENSE AGREEMENT

Copyright (c) 1999 - 2011 by B & M Konsultatsioonid Inc. All rights reserved.  TK8 Productions is
the project of B & M Konsultatsioonid Inc. TK8 and logos with TK8 are registered trademarks.

By using, copying, transmitting, distributing or installing TK8 Safe, you agree to all of the terms of
this License.  If you do not agree to any of the terms of this License, then do not use, copy,
transmit, distribute, or install TK8 Safe.

TK8 Safe is not the free software.  Subject to the terms below, you are hereby licensed by B & M
Konsultatsioonid, Inc ("BMK") to use this software for evaluation purposes without charge for a
period of 30 days (trial period).  

If you use this software after the 30-day evaluation period a registration fee is required. See the TK8
Safe web site at www.tk8.com for information about ordering.

Unregistered use of TK8 Safe after the 30 days is in violation of U.S. and international copyright laws
and treaties, as well as in other intellectual property laws and treaties.

You may, without making any payment to BMK:
1. Install and use shareware evaluation version of TK8 Safe free of charge for 30 days.

Subsequent downloads or installations of TK8 Safe do not extend, renew, or otherwise
restart your 30-day evaluation period.

2. Give exact copies of the shareware evaluation version of TK8 Safe personally to anyone,
except for the purpose of extending their 30-day evaluation period.

3. Distribute exact copies of the shareware evaluation version of TK8 Safe, if done exclusively
through electronic channels.

4. Make as many exact copies of the shareware evaluation version of TK8 Safe as you wish,
for purposes of distribution as described in (2) and (3) above.

YOU ARE SPECIFICALLY PROHIBITED FROM CHARGING, OR REQUESTING DONATIONS, FOR
ANY COPIES, HOWEVER MADE, AND FROM DISTRIBUTING SUCH COPIES WITH OTHER
PRODUCTS OF ANY KIND, COMMERCIAL OR OTHERWISE, WITHOUT PRIOR WRITTEN
PERMISSION FROM BMK. BMK RESERVES THE RIGHT TO REVOKE THE ABOVE
DISTRIBUTION RIGHTS AT ANY TIME, FOR ANY OR NO REASON.

THIS SOFTWARE, AND ALL ACCOMPANYING FILES, DATA AND MATERIALS, ARE
DISTRIBUTED "AS IS" AND WITH NO WARRANTIES OF ANY KIND, WHETHER EXPRESS OR
IMPLIED. THE USER MUST ASSUME THE ENTIRE RISK OF USING THIS PROGRAM.  THIS
DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THE AGREEMENT. IN
NO EVENT SHALL BMK, OR ITS PRINCIPALS, SHAREHOLDERS, OFFICERS, EMPLOYEES,
AFFILIATES, CONTRACTORS, SUBSIDIARIES, OR PARENT ORGANIZATIONS, BE LIABLE FOR
ANY INCIDENTAL, CONSEQUENTIAL, OR PUNITIVE DAMAGES WHATSOEVER RELATING TO
THE USE OF TK8 SAFE OR YOUR RELATIONSHIP WITH BMK.

IN ADDITION, IN NO EVENT DOES BMK AUTHORIZE YOU TO USE TK8 SAFE IN APPLICATIONS
OR SYSTEMS WHERE TK8 SAFE'S FAILURE TO PERFORM CAN REASONABLY BE
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EXPECTED TO RESULT IN A SIGNIFICANT PHYSICAL INJURY, OR IN LOSS OF LIFE.  ANY
SUCH USE BY YOU IS ENTIRELY AT YOUR OWN RISK, AND YOU AGREE TO HOLD BMK
HARMLESS FROM ANY CLAIMS OR LOSSES RELATING TO SUCH UNAUTHORIZED USE.

This Agreement is the complete statement of the Agreement between the parties on the subject
matter, and merges and supersedes all other or prior understandings, purchase orders, agreements
and arrangements. Without prejudice to any other rights, BMK may terminate this license
agreement if you fail to comply with the terms and conditions of this license agreement. In such
event, you must uninstall and destroy all copies of the TK8 Safe.

All rights of any kind in TK8 Safe which are not expressly granted in this License are entirely and
exclusively reserved to and by BMK. You may not rent, lease, modify, reverse engineer, decompile,
disassemble or create derivative works based on TK8 Safe. There are no third party beneficiaries of
any promises, obligations or representations made by BMK herein. 

END.
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